Support de stockage non accessible


Bonsoir chers tous,
Je suis nouveau sur Maarch RM. J’envisage de proposer cette solution chez nous. Mais avant je dois pouvoir la configurer.

Le problème que j’ai, illustré en image, se produits quand je veux importer un fichier.

Avez vous une piste de solution ?

S.O.S un coup de pouce pour venir à bout de ce problème et le classer comme un incident :pray:t5:!

C’est la capture de l’évènement dans le journal de Maarch RM.

Hello

Je ne vois que des problèmes de permission sur des répertoires. Dans /opt/maarch/docservers peut-être?

2 J'aimes

Merci George,
Je regarde dans cette direction pour voir ,ce que ça donne.

Ce chemin n’existe pas chez moi. J’ai juste
/opt/
Et il est vide.

J’ai donné l’exemple de Maarsh Courrier, mais j’imagine qu’il doit y avoir quelque chose de similaire pour le stockage dans Maarsh RM.

Dans maarchRM les storages sont dans le dossier de maarch :
/var/www/laabs/data/maarchRM/repository/
Ils appartiennent tous a mon utilisateur maarch et www-data

J’ai également pensé à un problème de droit d’accès mais je ne sais pas dans quel fichier aller voir pour configurer les options de connexion du filesysteme.

Bonjour Dero993,

Effectivement, il faut que les répertoire renseignés dans la configuration au niveau des supports de stockage appartiennent au « user » exécutant le serveur apache.
Si celui-ci est « maarch » par exemple avec le groupe « www-data », il faut que les 2 supports de stockages appartiennent à « maarch:ww-data » avec des droits 755 (pour un serveur linux).

les commandes sont :
sudo chown -R maarch:www-data /var/www/laabs/data/maarchRM/repository/
sudo chmod -R 755 /var/www/laabs/data/maarchRM/repository/

Pour voir exactement quels sont les chemins des répertoires de stockages, vous les trouverez dans « Gestion du stockage » -> « Supports de stockage » (voir captures d’écrans).

NB : Pour savoir quel user et groupe exécute le serveur apache, vous trouverez la configuration dans /etc/apache2/envvars

point_config

Librement,

Arnaud.

Salut Arnaud,
Merci bien pour l’aide.
Je teste la manip une fois sur ma machine et vous reviens. Je pense bien que c’est la solution à mon problème. J’ai pas affecter les droits au groupe www-data.