Installation maarchRM

Bonjour à tous ! :wave:

J’ai plein de documents à classer.
MaarchRM est-il l’outil qu’il me faut ?
Je verrai… quand il sera installé !

Sans rien connaître à Linux, ni aux bases de données, ni à la gestion de documents (oui, j’accumule les tares ! :smiley: ), je suis en train de galérer…
J’ai d’abord installé Debian sur une machine virtuelle.

En suivant les instructions ici :
Installation du socle d’archivage de Maarch RM · Documentation Maarch RM
…je me suis trouvé coincé vers la fin… au moment du redémarrage d’apache (une erreur avec RewriteEngine) que j’ai surmontée en ayant trouvé cette commande (tapée, évidemment, sans la comprendre !)
ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/rewrite.load

Mais au moment de lancer http://maarch dans mon navigateur, j’obtiens ceci :

*. / // Require base script require_once(’…/core/laabs.php’); laabs::init(); switch (true) { // OpenAPI and other utils case (pathinfo($_SERVER[‹ SCRIPT_NAME ›], PATHINFO_FILENAME) == ‹ openapi ›): switch (pathinfo($_SERVER[‹ SCRIPT_NAME ›], PATHINFO_EXTENSION)) { case ‹ json ›: require_once ‹ …/core/Openapi.php ›; $openapi = new core\Openapi(); $body = json_encode($openapi, JSON_PRETTY_PRINT + JSON_UNESCAPED_SLASHES); header(‹ Content-Type: application/json; charset=utf-8 ›); header('Content-Length: '.strlen($body)); echo $body; break; } break; // Uri is a static resource case (strrpos($_SERVER[‹ SCRIPT_NAME ›], « . »)): \core\Kernel\StaticKernel::start(); \core\Kernel\StaticKernel::run(); \core\Kernel\StaticKernel::end(); break; // Instance has a view case !\laabs::isServiceClient(): \core\Kernel\PresentationKernel::start(); \core\Kernel\PresentationKernel::run(); \core\Kernel\PresentationKernel::end(); break; // Instance is a service provider case \laabs::isServiceClient(): default: \core\Kernel\ServiceKernel::start(); \core\Kernel\ServiceKernel::run(); \core\Kernel\ServiceKernel::end(); }

J’ai loupé quoi ???
:thinking:

Merci pour votre aide !

Bonjour Lamass66,

Je pense que c’est du côté des pré requis d’installation que vous avez probablement sautez une etape, avez vous bien installer au préalable tous les packages listés sur ce lien ? Prérequis pour Maarch RM · Documentation Maarch RM

Pour les installer sur ubuntu, il suffit d’utiliser la commande sudo apt-get install nom-du-package et vous devriez pouvoir lancer maarchRM

Librement,

1 J'aime

Merci !
C’était bien ça !
:smiley:

Bon, maintenant, je vais pouvoir commencer à voir comment comment lui « donner à manger » et comment ça fonctionne.
Au boulot… dès que j’aurai un moment !

Pas de probleme content d’avoir pu vous aider,

Au cas où, ces guides de visite peuvent vous aider à l’utilisation des fonctionnalités de base des l’applications :

MaarchRM => https://cdn.maarch.org/demorm/MaarchRM_Guide2Visite_SpherePrivee.pdf
MaarchRMAP (avex extension Archives Publiques) => https://cdn.maarch.org/demorm/MaarchRM_Guide2Visite_SpherePublique.pdf

Librement,

Bonjour moi j’ai ce problème